Jump to content

Joe Mullins

Members
  • Content count

    15
  • Joined

  • Last visited

Everything posted by Joe Mullins

  1. Has anyone tried charging SWIT S-8073N NP-1 batteries on the IDX JL-2Plus charger? These batteries offer higher capacity, 2 d-taps, and are cheaper than the traditional IDX NP-1's.
  2. A little rattle in my MKH50

    The other day I noticed that one of the set screws holding the XLR connector in place fell off my 50. I didn't notice rattling before replacing the screw but perhaps that's something to check first.
  3. SWIT S-8073N NP-1 Battery with IDX charger?

    Ok thanks Glen.
  4. Another TA5 low profile! Not right angle this time

    @Forward Sound Well done, these are great. I too would be interested in cables or at least learning how you are making these.
  5. I heard there are some folks out there who believe the Sound Devices 664 sounds better than the 688. Does anyone out there share this opinion? I'd love to hear some comments on this and some explanations as to why the 664 might sound "better". [I currently own a 633 and have spent a fair amount of time working with the 688 (which I love). I am planning on purchasing the 688 for the additional channels, ability to use the SL-6, Dugan/MixAssist, and to have EQ control with the CL-12. The 664 would give me only 1/4 of those features.]
  6. Sound Devices 633 Distortion Issues

    Hope you've solved this problem by now but I had a similar problem and it drove me nuts. Did a car interview scene for a documentary with a high profile client and VERY limited time. Was in total fear that the tracks would have crackle all over lines rendering them unusable. Turns out it was my headphone cable! So I say give that thing a good wiggle and make sure thats not it. I cannot imagine why you would hear noise through the TA3 inputs when they are turned off.
  7. Wisycom RF Interference

    Had a shoot in a building that may or may not have had an FM radio station broadcasting from it in the Mid-Wilshire district of Los Angeles. Multiple frequency scans with my Wisycom MCR42S receivers with the latest firmware produced many clear frequencies with very low noise floors. Upon dialing up the transmitters (MTP40S with latest firmware), the gain level on the transmitter showed that the lav mic cable was acting like an antenna and picking up all kinds of stray RF. Here's a photo of the transmitter gain level in a silent room with a DPA 4061. Tried a B3 and COS-11 and got the same results. At the mixer, it sounded like the signal was gating (compander pumping?) and the gain level on receiver was almost nonexistent except in peaks of dialogue when the compander would fully open up. Tried both ENR and ENC modes. Made sure tone squelch was on. Raised squelch and no change. Tried multiple transmitters, all with the same results. Tried multiple open frequencies. Any solutions to this problem? Thanks.
  8. Has anyone had any success pairing an Apple Wireless Keyboard with the Sound Devices 970? If so, how did you do it? I'd also love to use it with my 633, but getting it to work with the 970 is the priority for now. Thanks!
  9. Apple wireless keyboard + Sound Devices 970 / 6-Series?

    Thanks everyone for your input! As a temporary workaround I have my Apple Wireless Keyboard controlling PIXNET on my iPad. Richard, if you don't mind sharing, which model Logitech keyboard are you using with the 970?
×