Jump to content

Search the Community

Showing results for tags 'xantrex'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Main Board
    • Current
    • The Daily Journal
    • General Discussion
    • Equipment
    • Cameras... love them, hate them
    • Recording Direct to Computer
    • Workflow
    • The Post Place
    • Images of Interest
    • Macs... and the other computer
    • All Things Apple
    • Technical Reference
    • Do It Yourself
    • Manufacturers & Dealers
    • Work Available - Available for Work
    • Post to the Host
  • JWSOUND RESOURCE
    • Donate to Support JWSOUNDGROUP

Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


About

Found 1 result

  1. Xantrex inverter won't… invert

    My cart is AC-powered. After a couple of years of getting power with a Samlex inverter and a separate charger, I decided to buy a Xantrex Freedom HF 1050 inverter/charger, to simplify my workflow, following the recommendation of Phil Palmer, Richard Lightstone and others. I have a Furman power conditioner, which feeds a number of devices: a Mackie Onyx FW mixer, a Venue receiver, a BlackMagic dual SDI monitor, two Comtek base stations and a Mac laptop. Power comes from a 34Ah gel battery. I installed the inverter and set up everything as per the instructions. Everything works fine when connected to house power: the Furman shows 112-120 V, the battery is being topped off, hovering around 13.8V and all the devices work as expected. However, when I unplug the AC power, everything dies - and the Furman starts blinking, eventually causing an overload alarm on the Xantrex. Everything is exactly the same as when I had the Samlex connected, so I can't figure out what could be wrong. I called Schneider this morning, and the tech had me connect an unrelated device (without involving the Furman.) No problems. The next step will be to connect all the devices in the cart to a regular power strip and connect it to the Xantrex. I will be doing so tonight - but, in the meantime, I wonder if anybody here might have a similar experience, or is able to shed some light on this problem. TIA! I forgot to mention that the system consumes less than 150W… So if a 300W inverter was sufficient, I would think that a 1KW one would be no problem.
×