Jump to content
Sign in to follow this  
480sound

Lectrosonics IFB 1/8" connector

Recommended Posts

I several complete Lectrosonics IFB blocks for separate feeds to director, boom and utility. I have consistent problems with the 1/8" headphone connector on the R1A. You can not take it apart in the field and service the connector. Outside here in New Mexico there is pretty much a constant wind filled with dirt and dust. It works into these connectors and makes them noisy and intermittent and fail. You have to send the receiver into to be repaired. The connector is a sealed panel mount and has to be replaced. Has anyone else had this problem and found a solution?

With Respect 

Share this post


Link to post
Share on other sites

Because of the "lever factor" inherent with a 1/8" connector sticking up from the Lectrosonics receivers and pressing against one's hip, the internal receptacle gets bent over time and loses connection. A temporary MacGyver field fix is to carefully unscrew the knurled nut, and flip over the thin black spacer underneath. Then replace the nut and experiment with the tension so that the headset connection is completed. My only workable permanent solution has been to only use right angle headset connectors with the R1 and R1a receivers.

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×