Sign in to follow this  
Followers 0
Trey LaCroix

Sennheiser 816 (p48) hiss and crackling noise

15 posts in this topic

Hey everybody! The other night I plugged in my 816 (phantom powered) and I noticed a loud-ish hiss and crackling noise. I tried it with a couple different power supplies to see if that was the issue, but same thing with each one. I'm taking it in to be looked at tomorrow, but wanted to check here to see if anyone has experienced this.

Thanks!

Share this post


Link to post
Share on other sites

That's the sound of it dying. However it can be brought back to life chez Sennheiser. 

Share this post


Link to post
Share on other sites

Thanks guys. Yep, that seems to be the case. Waiting to hear from the service department what the cost of a new capsule (and possibly s new preamp) will be. Hope it's not too expensive because I love that mic!

Share this post


Link to post
Share on other sites

It might not even be the capsule it could just be a component.  Capsules are generally pretty expensive.  Good technician or Sennheiser should get you going in no time. 

Share this post


Link to post
Share on other sites

Yeah it could just be a single component that needs replacing. Most likely not the capsule. 

Share this post


Link to post
Share on other sites

A leaky capacitor is a likely suspect.  

You might wish to contact Pete Verrando and see if it's something he would tackle.

Share this post


Link to post
Share on other sites

I sent an on again off again crackling and hissing 816t to sennheiser years back. They had it over two months. Possibly three. Made several calls into the office asking if all was well. Took a while because it was intermittent. They said. Finally got it back. No charge. And, no fix... and no explanation.

Share this post


Link to post
Share on other sites

Pete Verrando is awesome. He just did some work for me on a schoeps cmc4 and it only took a day and super low cost. I highly recommend you contact him as well. 

Share this post


Link to post
Share on other sites

Thanks for the responses everyone. Mark at Location Sound is pretty confident that it's the capsule, but maybe a second opinion isn't a bad idea. Especially since the price of a new capsule is twice the price I paid for my 816 used. I'll give Pete a call.

Share this post


Link to post
Share on other sites

Just curious if you ever figured out how to fix your 816?   I have one that needs to be looked at but Senn said they won't service them anymore.    

Share this post


Link to post
Share on other sites
On 5/8/2017 at 6:01 AM, Mack said:

Just curious if you ever figured out how to fix your 816?   I have one that needs to be looked at but Senn said they won't service them anymore.    

Just got my 816 back from Pete Verrando with the issue SOLVED! I guess a few things in on the board needed to be re soldered. Can't say enough good things about that guy! You should definitely hit him up if your 816 needs some looking at.

Share this post


Link to post
Share on other sites

Can you PM his contact for me?   Thanks! 

Share this post


Link to post
Share on other sites
42 minutes ago, Mack said:

Can you PM his contact for me?   Thanks! 

Or you could go to all the trouble of doing a search here for his info which is readily available.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0