Jump to content
Lauri Laagus

MKH8060 weird noise

Recommended Posts

millar   

My 8050 did the exact same thing, sennheiser gave me a warranty replacement. The newer models have a silver ring between the mic body and the xlr adaptor and they have apparently fixed the issue on them.

Share this post


Link to post
Share on other sites

Does your 8060 have the silver ring in between the xlr connector module and the microphone? I got Sennheiser to replace my 8060s and 8050 as a part of warranty replacement.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 4/30/2017 at 0:00 PM, ayushahuja said:

Does your 8060 have the silver ring in between the xlr connector module and the microphone? I got Sennheiser to replace my 8060s and 8050 as a part of warranty replacement.


Sent from my iPhone using Tapatalk

Can you upload a pic of your 8050? I wasn't aware that they had updated versions with the metal ring. (My 8060 has been updated and has a metal ring.) but both my 8050 and 8070 do not

Share this post


Link to post
Share on other sites
Can you upload a pic of your 8050? I wasn't aware that they had updated versions with the metal ring. (My 8060 has been updated and has a metal ring.) but both my 8050 and 8070 do not


Travelling this week but I'll put it up when I'm back. My 8040s (from 2012) are ringless whereas the replaced 8060s and 8050 have a ring.




Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×