Jump to content
millar

SMA 50 ohm termination

Recommended Posts

Hey all,

  Im using a PSC sma multi rf distribution. Does anyone know if the unused SMA connectors on the distro box need to have 50 ohm terminators on them? I am only using 5 out of the 8 pairs of outputs and am getting all sorts of RF interference that I am not used to getting. Worst culprit is the AD's walkies (Ch 1 is set to around 750 mHz), I'm using primarily block 21 (550 mhz). thanks

Share this post


Link to post
Share on other sites

I too have some crazy RF showing up when I power in the Multi. I was told by PSC that terminators on the open SMAs are unnecessary. PSC even sent me a brand new one to test, but it yielded the same results. I'd love to know if you (or anyone else) has success with terminating the unused SMAs. I still can't figure out my problem and I've tried every cable swap imaginable. 

 

Cheers,

Evan Meszaros

Share this post


Link to post
Share on other sites

I am very interested in learning how these concerns are evaluated and hopefully solved.

 

I have been interested in adding an active splitter to my tool set, and the comments above are discouraging.

 

Thank you for highlighting the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×