Jump to content

Weird digital noises coming from Sennheiser G3 receivers


Ryan Farber
 Share

Recommended Posts

I have recently been experiencing odd noises coming from my G3 receivers. The noises sound digital in nature, its not static or RF interference. I noticed that the noise is only apparent when the backlight on the screen of the receiver turns off. When you press a button to wake the screen back up again the noise goes away. The noise is also synchronous with the the little LCD display, in other words, when something moves on the display (like the audio level indicator) when the backlight is off, you hear the little digital artifacts.

It is very odd, and very annoying.

I recorded a sample of the noise. The first part is the noise by itself, with the lav on the transmitter muted. The second part is the noise with the lav on, and how it reacts when there is sound going through.

Anyone have any ideas?

Here is the link to the audio file.

Link to comment
Share on other sites

don't feel bad Ryan. I had a problem years ago when I plugged a Sony RF receiver into my 442. sounded bad, no low end, kind of pinched sounding. couldn't figure it out. sure enough: T-power was switched on. switched it off, problem solved. when I plugged Lectro receiver into same T-powered input there was no problem. balanced (Lectro) vs. unbalanced (G3) the reason?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...