Jump to content

CL-12 not picked up by SD664

Louw Verwoerd

Recommended Posts

Howdy folks,

Seldom do I take the liberty to appeal for help on these boards, but this occasion is something special.

I'm starting a feature this coming Tuesday (with a maximum ISO track count of 12). I imported an SD CL-12 Alaia for this occasion. So basically I'm maxing out the SD 664.

Here's the skinny: Brand new, out of the box, I plugged it in as per the literature and with the 3.10 Firmware still loaded, the 664 picked up the CL-12, installed the drivers and recommended the additional 5V mini USB power (I already supplied it). Just to note that before even powering up the 664 for the first time, the extra 5V feed would light up the small green power light on the Cl-12. The console powered up and I ran a quick couple of checks with the short cut keys, all great. Satisfied, I powered down and disconnected, focusing my attention on prepping the wireless workflow. On the side I decided to update the 664 firmware to 4.01, since I would probably get a Wingman in the future.

A couple of days later (today) I reach the point of fine tuning my bagged mixer with receivers combo to work with the Alaia I installed in a flight case. Plug everything in and power it on... No Cl-12. The lights don't cycle on (except the green power LED). The 664 displays the menu option for the CL-12 in gray, so it can't be selected. I've tested different cables. Tried the machine on my SD 633, exact same results (gray CL-12 in the menu).

Curious: previously the 5V feed would light up the green power light. Not so any more. Only once the 664/633 is connected, does the green LED light up with an inconstant pulse. Could it be that the 5V power port is bust and because of it, the CL-12 can't 'boot up'?

The port of the 664 is not faulty. A keyboard works fine on it. I even rolled back to firmware 3.10. No difference.

Any suggestions would be appreciated.



Link to comment
Share on other sites

Curious to what source you are using for the 5v mini usb power.  Using my remote audio BDSv4U w/ IDX Li NP1 L7S,  works intermittently... But using a cheap USB power bank works flawlessly and lasts days w/o recharging. I've given up on the USB BDS power. Whatever source you are  using my guess is that it's not getting enough power. 

Link to comment
Share on other sites

  • 2 weeks later...

Hi Louw,

Hope all is well.  I understand you've been in communication with SD Tech support and this issue was due to the power boost not supplying enough power on your CL-12 but switching the DC boost source solved the issue.   Just in case someone else runs into this type of issue, they can try this as well.  Thanks! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...