Jump to content
Calpacino

Sound Devices USBPre 2 issues

Recommended Posts

Is anyone on here using/has used the USBPre 2 usb interface? I've been having strange problems since I got it relating to Pro Tools. It's a strange occasional audio delay, the timeline cursor will move then I'll hear audio about a second later. The video engine also crashes whilst this is happening. This is my second unit as the first one was replaced on warranty. I've done everything under the sun to try and remedy it to no avail. My theory is it's a driver issue (I'm on windows 10).  

Of course I've been dealing with Sound Devices support for a while now but they're stumped too.

Share this post


Link to post
Share on other sites

Yes, I get this annoying issue in Pro Tools under windows 10. It has not always happened, sometime after v12 it kicked in.

 

It seems slightly unstable in its additional latency - often with a burst of audio after stopping the timeline as a precursor the issue manifesting.

 

The delay can be anywhere from .2 of a second up to about 2 seconds in my experiences - I have found no fix, no other mention on any other website/forum, or even any knowledge of this from SD support.

 

Interestingly, the meters in PT seem to bop along in time with the visible waveforms, but the hardware LED meters on the USBPre2 bop in time with the audible output. Suggesting that there is something clogging up the pipes between the ASIO output of PT and the hardware output.

 

You are not going mad, you are not alone, if I work out wtf is going on and find a fix, I shall post it here. Would you also do the same?

 

My USBPre2 is awesome under every other DAW in windows 10, and as awesome as I would allow PT to be described under OSx. I think this is a PT issue rather than anything else.

Share this post


Link to post
Share on other sites

I use my USBpre2 in Windows 7 and 10. Cubase, Nuendo, Wavelab and StudioOne runs like a charm.

 

Haven't used it with Pro Tools. Seldom fire up ProTools HD, and when I do, it's on my main studio computer.

 

How about trying the USBpre2-drivers together with the ASIO4ALL drivers? Sometimes ASIO4ALL fixes unstable ASIO-drivers really well and will be the bridge between the DAW and the hardware.

 

I've compared the sound-quality of USBpre2 with a bunch of soundcards and external converters, and the USBpre2 sounds great in comparison. So, it's definitely worth its price.

 

 

Good luck

Fred

Share this post


Link to post
Share on other sites

Response from AVID:


Please keep in mind that USBpre2 is not a supported audio interface for Pro Tools based on the following chart: 
http://avid.force.com/pkb/articles/en_US/Compatibility/Pro-Tools-HD-12-Approved-Audio-Interfaces-and-Peripherals

For the troubleshooting steps, please see below:

First of all, please clarify if the issue is happening only with USBpre2 or if this is happening with any other audio interface connected and set as Playback Engine. 

Secondly, please install ASIO4ALL from asio4all.com, set it as Playback Engine and route the signal through USBpre2. 
See if the latency persists on the same level. 


If the issue is still there, please complete the optimization process. This is highly recommended and can resolve many issues: 
http://avid.force.com/pkb/articles/en_US/troubleshooting/en367983

Also, rebuild Pro Tools preferences:

Mac:
1. With Finder as the active application, click on the Go menu, hold the Option key and click Library.
2. Click on the Preferences folder and move the following items to a separate folder on desktop:
	•	Preferences > Avid > Pro Tools
	•	com.avid.ProTools.plist 

Win:
Go to C:Users > *Your User Name* > AppData > Roaming > Avid and delete the Pro Tools folder. Then, restart your computer.
	•	Note: If you cannot find the AppData folder, click on the View tab, above Show/hide check Hidden Items. 

 

 

So, worse than useless. We are on our own I'm afraid. I find ASIO4ALL to be a bit of a dogs dinner, but will try and try again until I can get my head around it, then report back.

Share this post


Link to post
Share on other sites
On 8/1/2018 at 8:25 PM, Mikataudio said:

 

So, worse than useless. We are on our own I'm afraid. I find ASIO4ALL to be a bit of a dogs dinner, but will try and try again until I can get my head around it, then report back.

 

Yeah, it's 2018 and AVID still can't make its DAW play nice with soundcards using ASIO-drivers in Windows.

 

Don't rule out ASIO4ALL before trying it properly. Of course, it would be desirable to not use it, but if it works and even AVID themselves suggest using it, then it's worth trying, me thinks.

 

It's Pro Tools, so please put on your silk gloves before using. :-)

 

 

Cheers

Fred

Share this post


Link to post
Share on other sites

Thanks for the replies everyone, I'm the same I see the meters bouncing on PT then about a second later they bounce on the physical device. Asio4All does completely fix the problem, but then I can't use Basehead at the same time so it's pretty useless to me in my workflow. I've got Sound Devices back to the drawing board though so that's good. Cheers everyone!

Share this post


Link to post
Share on other sites
1 hour ago, Calpacino said:

Asio4All does completely fix the problem, but then I can't use Basehead at the same time so it's pretty useless to me in my workflow. I've got Sound Devices back to the drawing board though so that's good. Cheers everyone!

 

Ah, okay, I see. Well, ASIO4ALL don't do multi-client ASIO.

 

What you can do, is to use another soundcard (internal PC soundcard) for Basehead and send the audio to the line inputs of the USBpre2 and mix between the sources using the PRE/PC knob set to twelve o'clock.

 

But, it's not kosher.

 

I guess chances are small, that AVID steps up and fix their soundcard compatibility.

 

 

Cheers

Fred

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×