Jump to content

Audio Files from Deity BP-TRX with zero Duration - Corrupt Recording


Sound
 Share

Recommended Posts

Hi everyone. For the first time I have a massive recording issue with the new BP-TRX Audio recorder.

As always I synced the files with my video in Post, but the file from one transmitter/recorder shows a duration of zero seconds in tentacle sync studio, although it can be played back perfectly fine in VLC and timecode can be read from tentacle sync. In LTCconvert I cannot even import the file. File size on both recorders is about the same, so the file should be ok. What can I do to make it readable again and keep the embedded timecode??

Screenshot 2021-09-26 at 19.10.24.png

Link to comment
Share on other sites

  • Sound changed the title to Audio Files from Deity BP-TRX with zero Duration - Corrupt Recording

No chance in Wave Agent. I tried to import in Final cut, no chance.

Today I did a low format on all cards and tried it again.

But this time, five of my eight files are corrupt.

The whole shoot is completely ruined.

This thing is absolutely unreliable, I will have to return it.

 

 

Screenshot 2021-09-27 at 18.37.47.pngScreenshot 2021-09-27 at 18.42.23.png

Link to comment
Share on other sites

Avid and Resolve can Import, but show no duration and cant play it back.

Logic Pro cant recognize the file.

And apple compressor says failed: 3x CAVFmedia:: duration: no valid samples.

Guess I am completely screwed.

 

Screenshot 2021-09-27 at 18.56.43.png

Screenshot 2021-09-27 at 19.00.15.png

Screenshot 2021-09-27 at 19.02.00.png

Link to comment
Share on other sites

In audacity, you can open the sound as .raw audio data, which means that it will only read the audio of the file, then you can export it to a new wav file but the timecode will be stripped, of course. 

I'm guessing what's happened is that the bptrx hasn't successfully written the Metadata correctly into the file. 

 

If you decide to give audacity a try, know that in order for the raw audio to sound correctly you need to know the exact bit and sample rate, otherwise it'll just produce noise. 

Also, if you can somehow resolve the first frame timecode, you can amend the missing timecode in wave agent after recovering the audio, iirc

 

If you feel burned, I'd be happy to help. Send me a DM if so 

Link to comment
Share on other sites

Ya, I've used Audacity to "uncorrupt" audio files that got corrupted when the recorder was turned off or lost power before the file header was written as it would be if the file was closed/saved normally (I wonder if something like that happened with your transmitter/recorder). Audacity is free and straightforward; it's available here: https://www.audacityteam.org

 

But if you're feeling wiped and don't want to send the files to Olle (awesome offer of help Olle!), you could try VLC since you already have and are familiar with it. I just googled up this YouTube tutorial. It's from a few years ago, but turns out it's done by a friend who owns a software company. Anyway, he shows some WAV files with zero duration, so perhaps it's a similar issue to what you're facing. And the video has almost 50,000 views; this is a common problem...

 

If nothing else, a quick try with VLC might put your mind at ease before you try Audacity + Wave Agent as Olle suggests. Good luck.

 

 

Link to comment
Share on other sites

Thanks both of you! I already exported the audio via vlc with the setting „keep audio“, so everything should stay unchanged. Then I readied the tc with wave agent and synced it to the video with tentacle sync studio. But suddenly there was massive audio drift. Towards the end of one audio file it was about three seconds I guess. So maybe vlc got the wrong sample rate and I should try again with audacity, where I can set the sample Rate if I got it correctly..

Still I don’t think I can trust the internal recording of the transmitters anymore.. hope there will be a solution.

Link to comment
Share on other sites

Glad that you have audio files again! Bummer that it's going to take some work to get everything TC'd and sync'd. But still...

 

Maybe drop Deity a note and asked them what might have caused the issue. My guess is power lost or turned off before the files finished writing. But Deity might have some better thoughts...and perhaps a way to avoid or minimize the problem in the future. No idea if there is a solution, but worth at least asking. https://deitymic.com/support/

Link to comment
Share on other sites

I already contacted them two days ago, when there was only one corrupt file. Unfortunately I had to use them again the next day. First I thought maybe its a corrupt sd card and I did a low format on all cards. But now theres a massive problem on all recorders. I was careful and stopped recording before switching them off, although i would expect a device to store recorded files properly when switching off while recording

I am afraid I have no chance in audacity.

I tried both 24 bit settings annd entered 48000 khz, but theres only noise coming out.

Strange, that all the metadata seems available in mediainfo and tentacle sync, including the starting timecode, but no file duration.

 

Screenshot 2021-09-28 at 05.22.01.png

 

Screenshot 2021-09-28 at 05.20.52.png

Screenshot 2021-09-28 at 05.20.57.png

Link to comment
Share on other sites

I wasn't thinking you powered off incorrectly, but rather that maybe the tx/recorder somehow dropped power for short period. Like there's a faulty switch or something. No real idea. Total drag.

 

For me, once I get an error on a card, I ditch it. I don't try to resurrect it or have bad sectors (or whatever) mapped out. The things are comparatively cheap, and the aggravation a bad card causes...well, you know. 

 

Again, total bummer. Hang in there!

Link to comment
Share on other sites

You are right. Still I dont know if the card is the problem, they are quite new and it happened on both recorders - on two different cards. I just checked and shut down both of them two times while recording. No corrupt files. So maybe it has to do with the duration of the recording... With the mixpre 10 ii I never had a single corrupt file, now switching to those recorders seems a huge risk.

Link to comment
Share on other sites

Just ordered two new cards as well, but I guess I will not rely on the internal recording anymore. Ordered a Zoom F6 as well to record a backup. Its a pity that the wireless connection of the deity is not that reliable, so I cannot use them as transmitters for the f6 with internal backup recording. I will switch back to my sony uwp-d.. I guess

 

3 minutes ago, Olle Sjostrom said:

Tried importing into reaper?

Tried importing normally into audacity?

I too find vlc a bit tedious to use, a lot of trial and error and just by chance it'll work. 

I dont use reaper, but if I import normally, there is no waveform and no playback.. so I guess i have to stick to vlc.

Link to comment
Share on other sites

thanks again! Reaper batch conversion works and can even keep the timecode. Still the massive audio drift remains. But at least I dont have to dial in the timecodes manually and conversion is much quicker as with vlc - where i have to convert file by file.

Link to comment
Share on other sites

Using my WeTranfer (here)

I think the Data chunk is set to 0. Setting it to FFFFFFFF (if it's < 4 gig) should do the trick, or calculate the 'right' size.

What happens with drift. If the timestamp is there, there should be no drift.
I know that for Avid you can force the FPS. (Thus Avid won't ask how to interpret the timestamp.)
That's an easy fix as well, in the Bext chunk, remove the Speed (pad with space)
(Perhaps also comment out the iXML, if it's present)

Link to comment
Share on other sites

Thanks! You know what you are talking about! But sounds a little complicated to me.

How do you know, where the drift is going? And how can I remove the speed?

I sent you the files

46 minutes ago, Bouke said:

That's an easy fix as well, in the Bext chunk, remove the Speed (pad with space)
(Perhaps also comment out the iXML, if it's present)

 

By the way, i just checked: I can recreate the problem, when I pull out the card while recording. Exactly the same then: Large file with zero duration. Maybe the contacts of the internal sd card reader loose contact after some time. In the first weeks I had no problems at all with the same micro sd card. (sandisk extreme).

Link to comment
Share on other sites

10 hours ago, daniel said:

Have you tried contacting Deity customer support? And if so how was it?

They said it must be the sandisk card because all recording problems have been reported with these cards. So I had to get Samsung cards, and it’s exactly the same. Haven’t received an answer so far. Sounded like they don’t know another solution.

I think the problem shows more frequently when you record a long take, about an hour and than stop and immediately start recording remotely via the receiver. Like the Transmitter has no time to write the data in the recorded file. But i am not sure.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...