Jump to content

eye of the storm


osa
 Share

Recommended Posts

I have been battling touch faders on a control surface showing erratic behavior, dropping in and out during recording automation, fighting me during movements etc. I had been dealing with this off and on for months. Finally got around last couple days to hardcore troubleshoot. Got online with tech support, resinstalled supporting software, hardware tests, network troubleshooting...until late last night when i thought all hope was lost and ready to send these in for repair, i finally discovered the problem:

 

 

 

 

 

 

 

 

 

 

IMG_2550.jpg

 

 

I have had this since the 80's via my grandma as a gift. I have always kept it in the studio for maintaining contact with spiritual realms as well as a lighted indicator linked to the power conditioner powering studio speakers to indicate if they are on or off. It had never occurred to me that this thing was creating problems until running tests last night with speakers off and suddenly everything was working as it should. This plasma ball was spilling electrical energy all over the faders causing touch automation mayhem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...