Jump to content

Troubleshooting : DPA 4018 is not seating on brand new MMP-A preamp

Paul Garafola

Recommended Posts

My 4018 cap screws on easily & perfectly to my MMP-B and MMP-C pre-amps - and here's where it's giving me resistance on the MMP-A. (see photos)

In this moment, I do not want to take the chance on giving it more force, in order for it to seat as it should.  I don't want to make the problem worse.


If you've had this occur, is it an actual problem - or will it seat perfectly if I continue turning it past the resistance?  Did yours?


If you'd had this exact situation occur, what was the solution?


Thanks for your help.


 - Paul


4018 cap is not seating on BRAND NEW MMP-A.jpg

Link to comment
Share on other sites

Hi Roderick,

Yeah, I cleared and cleaned the threads on the MMP-A and still no progress. 

I would try the lubricant, but I really think the primary and only issue is a faulty thread.

So you've had this exact issue and the lubricant actually worked - and the capsule then attached easily??

(Yeah, if there's not a solid solution that people have succeeded with, then I'll just send it back for a warranty replacement.  But obviously, I'd like to not have to do that.)

Thanks for your reply.


 - Paul -

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...