Jump to content

Nomad Internal Pack Too Loose - Won't Power Nomad

Adam Aslan

Recommended Posts

Sooo my AA battery pack is too loose inside the Nomad and not powering the unit.

If I take off the cover and press it in harder it does power the unit, so there just needs to be something wedged in there to keep that pressure up.

I tried a nickel and that worked but was wondering if thats a bad idea?

Maybe cardboard? Any suggestions?

Dont really feel like sending it in.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...